ALT Linux Community general discussions
 help / color / mirror / Atom feed
* [Comm] texlive-2019 в p9?
@ 2020-10-13 10:35 Denis G. Samsonenko
  2020-10-13 10:47 ` Michael Shigorin
                   ` (2 more replies)
  0 siblings, 3 replies; 12+ messages in thread
From: Denis G. Samsonenko @ 2020-10-13 10:35 UTC (permalink / raw)
  To: community

День добрый!

Потребовалось после долгого перерыва воспользоваться latex'ом.

Система p9.

Вижу, что в репозитории p9 есть следующие пакеты:

texlive-2019-alt1_2
texlive-collection-basic-2018-alt1_5
texlive-context-2018-alt1_5
texlive-dist-2018-alt1_5
texlive-doc-2018-alt1_5
texlive-fontsextra-2018-alt1_5
texlive-texmf-2018-alt1_5
texmf-latex-obsolete-0.1-alt3


Это нормально, что пакет texlive версии 2019, а остальные версии 2018?

Оно в таком виде работает?


С текущим составом пакетов у меня не работает updmap:

Can't locate TeXLive/TLUtils.pm in @INC (you may need to install the
TeXLive::TLUtils module) (@INC contains: /usr/share/texmf/tlpkg
/usr/local/lib64/perl/5.28 /usr/local/share/perl/5.28 /usr/lib64/perl5
/usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5
/usr/lib/perl5/vendor_perl) at /usr/bin/updmap line 41.
BEGIN failed--compilation aborted at /usr/bin/updmap line 41.


Если добавить ссылку /usr/share/texmf/tlpkg ->
/usr/share/texmf-dist/tlpkg, то тогда запускается, но выдаёт другие
ошибки:

updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]:         fi4.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]:         morisawa.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]:         original-context-symbol.map (in
/usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]: Did you run mktexlsr?


-- 
Всего доброго,

Денис.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-13 10:35 [Comm] texlive-2019 в p9? Denis G. Samsonenko
@ 2020-10-13 10:47 ` Michael Shigorin
  2020-10-13 15:34 ` Igor Vlasenko
  2020-10-13 17:09 ` Igor Vlasenko
  2 siblings, 0 replies; 12+ messages in thread
From: Michael Shigorin @ 2020-10-13 10:47 UTC (permalink / raw)
  To: community

On Tue, Oct 13, 2020 at 05:35:36PM +0700, Denis G. Samsonenko wrote:
> С текущим составом пакетов у меня не работает updmap:

Всяко стоит повесить.

-- 
 ---- WBR, Michael Shigorin / http://altlinux.org
  ------ http://opennet.ru / http://anna-news.info


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-13 10:35 [Comm] texlive-2019 в p9? Denis G. Samsonenko
  2020-10-13 10:47 ` Michael Shigorin
@ 2020-10-13 15:34 ` Igor Vlasenko
  2020-10-14  3:35   ` Denis G. Samsonenko
  2020-10-14  4:30   ` Vladimir D. Seleznev
  2020-10-13 17:09 ` Igor Vlasenko
  2 siblings, 2 replies; 12+ messages in thread
From: Igor Vlasenko @ 2020-10-13 15:34 UTC (permalink / raw)
  To: ALT Linux Community general discussions

On Tue, Oct 13, 2020 at 05:35:36PM +0700, Denis G. Samsonenko wrote:
> День добрый!
> Это нормально, что пакет texlive версии 2019, а остальные версии 2018?
нет, это кто-то забыл скопировать.

поехало:
#259837 BUILDING #1 [locked] p9 srpm=texlive-texmf-2019-alt2_7.src.rpm
но в p9 оно попадет после тестирования, через неделю или две.

-- 

I V


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-13 10:35 [Comm] texlive-2019 в p9? Denis G. Samsonenko
  2020-10-13 10:47 ` Michael Shigorin
  2020-10-13 15:34 ` Igor Vlasenko
@ 2020-10-13 17:09 ` Igor Vlasenko
  2 siblings, 0 replies; 12+ messages in thread
From: Igor Vlasenko @ 2020-10-13 17:09 UTC (permalink / raw)
  To: ALT Linux Community general discussions

Спасибо, копирую остаток.

On Tue, Oct 13, 2020 at 1:47 PM Denis G. Samsonenko
<d.g.samsonenko@gmail.com> wrote:
>
> День добрый!
>
> Потребовалось после долгого перерыва воспользоваться latex'ом.
>
> Система p9.
>
> Вижу, что в репозитории p9 есть следующие пакеты:
>
> texlive-2019-alt1_2
> texlive-collection-basic-2018-alt1_5
> texlive-context-2018-alt1_5
> texlive-dist-2018-alt1_5
> texlive-doc-2018-alt1_5
> texlive-fontsextra-2018-alt1_5
> texlive-texmf-2018-alt1_5
> texmf-latex-obsolete-0.1-alt3
>
>
> Это нормально, что пакет texlive версии 2019, а остальные версии 2018?
>
> Оно в таком виде работает?
>
>
> С текущим составом пакетов у меня не работает updmap:
>
> Can't locate TeXLive/TLUtils.pm in @INC (you may need to install the
> TeXLive::TLUtils module) (@INC contains: /usr/share/texmf/tlpkg
> /usr/local/lib64/perl/5.28 /usr/local/share/perl/5.28 /usr/lib64/perl5
> /usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5
> /usr/lib/perl5/vendor_perl) at /usr/bin/updmap line 41.
> BEGIN failed--compilation aborted at /usr/bin/updmap line 41.
>
>
> Если добавить ссылку /usr/share/texmf/tlpkg ->
> /usr/share/texmf-dist/tlpkg, то тогда запускается, но выдаёт другие
> ошибки:
>
> updmap [ERROR]: The following map file(s) couldn't be found:
> updmap [ERROR]:         fi4.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
> updmap [ERROR]:         morisawa.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
> updmap [ERROR]:         original-context-symbol.map (in
> /usr/share/texmf-dist/web2c/updmap.cfg)
> updmap [ERROR]: Did you run mktexlsr?
>
>
> --
> Всего доброго,
>
> Денис.
> _______________________________________________
> community mailing list
> community@lists.altlinux.org
> https://lists.altlinux.org/mailman/listinfo/community



-- 
С уважением,
Игорь Власенко.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-13 15:34 ` Igor Vlasenko
@ 2020-10-14  3:35   ` Denis G. Samsonenko
  2020-10-14  3:55     ` Denis G. Samsonenko
  2020-10-14  4:30   ` Vladimir D. Seleznev
  1 sibling, 1 reply; 12+ messages in thread
From: Denis G. Samsonenko @ 2020-10-14  3:35 UTC (permalink / raw)
  To: ALT Linux Community general discussions

День добрый!

> > Это нормально, что пакет texlive версии 2019, а остальные версии 2018?
> нет, это кто-то забыл скопировать.
>
> поехало:
> #259837 BUILDING #1 [locked] p9 srpm=texlive-texmf-2019-alt2_7.src.rpm
> но в p9 оно попадет после тестирования, через неделю или две.

Скачал из собранного задания и поставил. Всё равно запуск updmap выдаёт ошибку:

Can't locate TeXLive/TLUtils.pm in @INC (you may need to install the
TeXLive::TLUtils module) (@INC contains: /usr/share/texmf/tlpkg
/usr/local/lib64/perl/5.28 /usr/local/share/perl/5.28 /usr/lib64/perl5
/usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5
/usr/lib/perl5/vendor_perl) at /usr/bin/updmap line 41.
BEGIN failed--compilation aborted at /usr/bin/updmap line 41.

На сколько я понимаю, TeXLive/TLUtils.pm находится в
/usr/share/texmf-dist/tlpkg, но такого пути нет в списке путей поиска
перловых модулей. Зато есть /usr/share/texmf/tlpkg, но его не
предоставляет ни один пакет. Если сделать ссылку
/usr/share/texmf/tlpkg -> /usr/share/texmf-dist/tlpkg, то тогда updmap
начинает работать.

-- 
Всего доброго,

Денис.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14  3:35   ` Denis G. Samsonenko
@ 2020-10-14  3:55     ` Denis G. Samsonenko
  2020-10-14 13:38       ` Igor Vlasenko
  0 siblings, 1 reply; 12+ messages in thread
From: Denis G. Samsonenko @ 2020-10-14  3:55 UTC (permalink / raw)
  To: ALT Linux Community general discussions

Hi!

ср, 14 окт. 2020 г. в 10:35, Denis G. Samsonenko <d.g.samsonenko@gmail.com>:
> Если сделать ссылку
> /usr/share/texmf/tlpkg -> /usr/share/texmf-dist/tlpkg, то тогда updmap
> начинает работать.

Запуск updmap-sys выдаёт ошибку:

updmap [ERROR]: The following map file(s) couldn't be found:
updmap [ERROR]:         CountriesOfEurope.map (in
/usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]:         fi4.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]:         morisawa.map (in /usr/share/texmf-dist/web2c/updmap.cfg)
updmap [ERROR]:         original-context-symbol.map (in
/usr/share/texmf-dist/web2c/updmap.cfg)

При этом я вижу файл CountriesOfEurope.map в
/usr/share/texmf-dist/fonts/map/dvips/countriesofeurope, остальные
перечисленные поиск не находит.

-- 
Всего доброго,

Денис.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-13 15:34 ` Igor Vlasenko
  2020-10-14  3:35   ` Denis G. Samsonenko
@ 2020-10-14  4:30   ` Vladimir D. Seleznev
  2020-10-14 13:30     ` Igor Vlasenko
  1 sibling, 1 reply; 12+ messages in thread
From: Vladimir D. Seleznev @ 2020-10-14  4:30 UTC (permalink / raw)
  To: ALT Linux Community general discussions

On Tue, Oct 13, 2020 at 06:34:22PM +0300, Igor Vlasenko wrote:
> On Tue, Oct 13, 2020 at 05:35:36PM +0700, Denis G. Samsonenko wrote:
> > День добрый!
> > Это нормально, что пакет texlive версии 2019, а остальные версии 2018?
> нет, это кто-то забыл скопировать.
> 
> поехало:
> #259837 BUILDING #1 [locked] p9 srpm=texlive-texmf-2019-alt2_7.src.rpm
> но в p9 оно попадет после тестирования, через неделю или две.

Если работоспособность пакета зависит от версии другого пакета, то разве
не надо делать версионированную зависимость?

-- 
   WBR,
   Vladimir D. Seleznev


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14  4:30   ` Vladimir D. Seleznev
@ 2020-10-14 13:30     ` Igor Vlasenko
  0 siblings, 0 replies; 12+ messages in thread
From: Igor Vlasenko @ 2020-10-14 13:30 UTC (permalink / raw)
  To: ALT Linux Community general discussions

On Wed, Oct 14, 2020 at 07:30:24AM +0300, Vladimir D. Seleznev wrote:
> On Tue, Oct 13, 2020 at 06:34:22PM +0300, Igor Vlasenko wrote:
> > On Tue, Oct 13, 2020 at 05:35:36PM +0700, Denis G. Samsonenko wrote:
> > > День добрый!
> > > Это нормально, что пакет texlive версии 2019, а остальные версии 2018?
> > нет, это кто-то забыл скопировать.
> > 
> > поехало:
> > #259837 BUILDING #1 [locked] p9 srpm=texlive-texmf-2019-alt2_7.src.rpm
> > но в p9 оно попадет после тестирования, через неделю или две.
> 
> Если работоспособность пакета зависит от версии другого пакета, то разве
> не надо делать версионированную зависимость?

это поменялась структура каталогов.
Раньше такого не было :( тяжкое наследие импорта.

-- 

I V


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14  3:55     ` Denis G. Samsonenko
@ 2020-10-14 13:38       ` Igor Vlasenko
  2020-10-14 14:37         ` Denis G. Samsonenko
  0 siblings, 1 reply; 12+ messages in thread
From: Igor Vlasenko @ 2020-10-14 13:38 UTC (permalink / raw)
  To: ALT Linux Community general discussions

On Wed, Oct 14, 2020 at 10:55:06AM +0700, Denis G. Samsonenko wrote:
> > Если сделать ссылку
> > /usr/share/texmf/tlpkg -> /usr/share/texmf-dist/tlpkg, то тогда updmap
> Запуск updmap-sys выдаёт ошибку:

updmap-sys отдельно лучше не дергать. У вас сейчас в /updmap.cfg
некорректные данные.
Лучше удалите ваши изменения в файловой
системе (ссылки и т.д.) и переустановите пакеты.
или хотя бы запустите от рута
/usr/sbin/texlive-postinstall-rebuild-all
но лучше для надежности переустановить пакеты (с texlive-dist-2019).

-- 

I V


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14 13:38       ` Igor Vlasenko
@ 2020-10-14 14:37         ` Denis G. Samsonenko
  2020-10-14 15:23           ` Igor Vlasenko
  0 siblings, 1 reply; 12+ messages in thread
From: Denis G. Samsonenko @ 2020-10-14 14:37 UTC (permalink / raw)
  To: ALT Linux Community general discussions

Вечер добрый!

> > > Если сделать ссылку
> > > /usr/share/texmf/tlpkg -> /usr/share/texmf-dist/tlpkg, то тогда updmap
> > Запуск updmap-sys выдаёт ошибку:
>
> updmap-sys отдельно лучше не дергать. У вас сейчас в /updmap.cfg
> некорректные данные.
> Лучше удалите ваши изменения в файловой
> системе (ссылки и т.д.) и переустановите пакеты.
> или хотя бы запустите от рута
> /usr/sbin/texlive-postinstall-rebuild-all
> но лучше для надежности переустановить пакеты (с texlive-dist-2019).

Удалил всё, что было связано с TeX. Вынес из системы оставшиеся
каталоги. Поставил заново:

tex-common
texlive
texlive-collection-basic
texlive-dist
texlive-fontsextra
texlive-texmf

Запускаю от пользователя updmap, получаю:

$ updmap
Can't locate TeXLive/TLUtils.pm in @INC (you may need to install the
TeXLive::TLUtils module) (@INC contains: /usr/share/texmf/tlpkg
/usr/local/lib64/perl/5.28 /usr/local/share/perl/5.28 /usr/lib64/perl5
/usr/share/perl5 /usr/lib64/perl5 /usr/share/perl5 /etc/perl5
/usr/lib/perl5/vendor_perl) at /usr/bin/updmap line 41.
BEGIN failed--compilation aborted at /usr/bin/updmap line 41.


-- 
Всего доброго,

Денис.

^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14 14:37         ` Denis G. Samsonenko
@ 2020-10-14 15:23           ` Igor Vlasenko
  2020-10-14 16:33             ` Denis G. Samsonenko
  0 siblings, 1 reply; 12+ messages in thread
From: Igor Vlasenko @ 2020-10-14 15:23 UTC (permalink / raw)
  To: ALT Linux Community general discussions

On Wed, Oct 14, 2020 at 09:37:34PM +0700, Denis G. Samsonenko wrote:
> $ updmap
> Can't locate TeXLive/TLUtils.pm in @INC (you may need to install the

теперь понял вас.
я у себя запустил updmap от пользователя, тоже получил
> Can't locate TeXLive/TLUtils.pm in @INC
но я не понял, почему вы запускаете updmap от пользователя.
После (пере)установки все должно работать из коробки,
руками вызывать updmap не нужно.
 
Вы у себя локально устанавливаете какие-то теховские файлы?

У меня под p9 latex работает из коробки, поэтому
я просто не могу понять, зачем вам вызывать updmap.

-- 

I V


^ permalink raw reply	[flat|nested] 12+ messages in thread

* Re: [Comm] texlive-2019 в p9?
  2020-10-14 15:23           ` Igor Vlasenko
@ 2020-10-14 16:33             ` Denis G. Samsonenko
  0 siblings, 0 replies; 12+ messages in thread
From: Denis G. Samsonenko @ 2020-10-14 16:33 UTC (permalink / raw)
  To: community

Hi!

> теперь понял вас.
> я у себя запустил updmap от пользователя, тоже получил
> > Can't locate TeXLive/TLUtils.pm in @INC
> но я не понял, почему вы запускаете updmap от пользователя.
> После (пере)установки все должно работать из коробки,
> руками вызывать updmap не нужно.
>
> Вы у себя локально устанавливаете какие-то теховские файлы?

Да, ставлю локально то, чего нет в дистрибутиве.

> У меня под p9 latex работает из коробки, поэтому
> я просто не могу понять, зачем вам вызывать updmap.

В любом случае нерабочий updmap из коробки выглядит странно.

-- 
Всего доброго,

Денис.

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2020-10-14 16:33 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-10-13 10:35 [Comm] texlive-2019 в p9? Denis G. Samsonenko
2020-10-13 10:47 ` Michael Shigorin
2020-10-13 15:34 ` Igor Vlasenko
2020-10-14  3:35   ` Denis G. Samsonenko
2020-10-14  3:55     ` Denis G. Samsonenko
2020-10-14 13:38       ` Igor Vlasenko
2020-10-14 14:37         ` Denis G. Samsonenko
2020-10-14 15:23           ` Igor Vlasenko
2020-10-14 16:33             ` Denis G. Samsonenko
2020-10-14  4:30   ` Vladimir D. Seleznev
2020-10-14 13:30     ` Igor Vlasenko
2020-10-13 17:09 ` Igor Vlasenko

ALT Linux Community general discussions

This inbox may be cloned and mirrored by anyone:

	git clone --mirror http://lore.altlinux.org/community/0 community/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 community community/ http://lore.altlinux.org/community \
		mandrake-russian@linuxteam.iplabs.ru community@lists.altlinux.org community@lists.altlinux.ru community@lists.altlinux.com
	public-inbox-index community

Example config snippet for mirrors.
Newsgroup available over NNTP:
	nntp://lore.altlinux.org/org.altlinux.lists.community


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git